The website has had stable image delivery for the past 6 hours, and we now consider the incident fixed. Thank you for your patience.
Posted Mar 17, 2025 - 12:35 UTC
Monitoring
A fix has been implemented to avoid cascading failures caused by image delivery breaking the website, however image delivery itself is still heavily degraded depending on your region.
We expect a return to normalcy within the next few hours, but it is for now largely out of our hands. We will be working towards improving the recovery of things in the future.
Posted Mar 16, 2025 - 23:22 UTC
This incident affected: CDN (Core, MangaDex @ Home).