DNS inconsistencies in some parts of the world
Incident Report for MangaDex
Resolved
As far as we can tell, most of even the slowest DNS servers are now properly updated. If you still have issues, we'd urge you to change your DNS servers to servers managed by competent people.
Posted Jul 22, 2023 - 08:42 UTC
Monitoring
Some people might be affected by stale DNS responses in parts of the world if their DNS servers of choices are bad.

Wait a bit or get better DNS servers. It is a good time to remind everyone that you should almost never use your ISP-provided/default DNS servers.

We can recommend the following options:
- Google DNS ( https://developers.google.com/speed/public-dns/docs/using )
- Cloudflare DNS ( https://1.1.1.1/dns/ )
- Quad9 ( https://www.quad9.net/support/set-up-guides )
Posted Jul 22, 2023 - 00:32 UTC
This incident affected: Website, API and CDN (Core, MangaDex @ Home).