A fix has been implemented. We will keep monitoring performance of image delivery until we're sure it is stable.
Posted Mar 05, 2026 - 20:00 UTC
Update
We uncovered a relatively complex issue on the way to fixing image delivery which slowed us down a lot. Unfortunately image performance is still degraded, but we decided to keep the website open for now while we investigate further.
Posted Mar 05, 2026 - 19:30 UTC
Update
We are continuing to investigate this issue.
Posted Mar 05, 2026 - 16:00 UTC
Update
We are taking the site down a few minutes to facilitate the investigation.
Posted Mar 05, 2026 - 15:32 UTC
Update
Performance is still degraded, but has been mostly mitigated. We continue investigating for the root cause of the issue.
Posted Mar 05, 2026 - 14:02 UTC
Investigating
We have identified a significant degradation in image delivery performance. We are investigating.
Posted Mar 05, 2026 - 11:22 UTC
This incident affected: Website, API and CDN (Core, MangaDex @ Home).