Storage Issue

Incident Report for MangaDex

Monitoring

A fix has been deployed and the wesbite is operating fully again. We're keeping an eye on it a few more hours before calling it resolved.
Posted Aug 01, 2025 - 10:34 UTC

Identified

A significant issue has been detected on our image storage system. We're working towards fixing it, but it's difficult to give an ETA right now.

For clarity's sake: No data was lost, but we have to limit usage to a minimum right now while repairs are ongoing.
Posted Jul 31, 2025 - 21:52 UTC
This incident affects: CDN (Core, MangaDex @ Home).