Traffic surge causing performance issues
Incident Report for MangaDex
Resolved
This incident has been resolved.
Posted Mar 31, 2024 - 17:16 UTC
Identified
We are preparing a fix as things stand. If you're affected, just wait a little bit more.
Posted Mar 31, 2024 - 17:11 UTC
Investigating
The number of people trying to use MangaDex right now is much much higher than usual, presumably as you all are enjoying your easter holidays.

This is amazing to see, but the servers are dying as a result.
We are forced to put things partially in maintenance as we go as a result.

We'll try to keep impact to a minimum, but can't promise much in immediacy.
Thanks for your understanding.
Posted Mar 31, 2024 - 17:11 UTC
This incident affected: Website, API and CDN (Core, MangaDex @ Home).