Performance issues
Incident Report for MangaDex
Resolved
We have implemented some changes that should keep things stable for the time being.
Posted Feb 18, 2023 - 04:28 UTC
Update
We continue investigating and have some ideas of how to improve things, but those will have to wait for later today (the 17th). Hopefully we get time to deal with it all shortly.
Posted Feb 17, 2023 - 02:25 UTC
Investigating
MangaDex is experiencing severe performance issues due to a massive increase in traffic.

While we work through the source of the issue you might experience occasional maintenance windows in your region. We are doing our best to resolve service as soon as possible.

Thank you for your patience.
Posted Feb 16, 2023 - 22:51 UTC
This incident affected: Website and API.