A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 17:48 UTC
Identified
A failover between network appliances has failed and the website is disconnected from the internet. We're working to retablish connectivity. Please wait.
Posted Mar 04, 2026 - 17:34 UTC
This incident affected: Website, API and CDN (Core, MangaDex @ Home).