While we are managing to serve some of the image traffic, clearly we aren't keeping up with demand and loading times are still very slow. We have however identified the bottleneck and will be working to address it.
Posted Mar 30, 2025 - 18:36 UTC
Update
Since things have been fine for now, we will keep monitoring but consider the issue presumably fixed.
Posted Mar 30, 2025 - 17:00 UTC
Monitoring
A fix has been implemented, but we will need to wait for a similar failure as the last times to see it perform live before we judge it as sufficient.
Posted Mar 29, 2025 - 00:19 UTC
Investigating
Image loading is extremely slow again in some region. While we have a rough idea of what is the cause, it is not so easy to address. We're actively working on it.
Posted Mar 17, 2025 - 20:01 UTC
This incident affects: CDN (Core, MangaDex @ Home).